Can't log in

Unfortunately, I can no longer rate levels or post new levels. It keeps asking for a login, and every time I try to login, it crashes out before I can even complete typing in my user/password etc. I've hard booted my iPhone, tried to make a new login etc etc and nothing works. I have a fully updated iPhone 6s if anyone has any advice


  • Hi Moochir,

    I'll look into this when I update RwK to work with the 64bit stuff.  But, to assist, could you see if the same thing happens if you deliberately enter the wrong password?
  • Yes it does. It won't let me even complete typing a password before it crashes out completely.

    Another odd thing, if I type a space at all when choosing a level name to post, it crashes out entirely. In other words, I could upload a level named poopboob no problem. But if I were to try to upload or name a level poop boob while editing, it crashes out as soon as I type the space
  • Oh, and thank you for your quick reply!
  • Okay, that sounds like just some sort of keyboard incompatibility has crept in with one of the Windows updates.  When I can get it all to recompile for the 64bit stuff, I'll see that it gets fixed.

    In the meantime, if you can tweak any keyboard options, you might end up with a situation where it can work.  For instance, if you have any keyboard helpers, etc, installed.
  • iPhone 6s, fully updated. No keyboard helpers. Installed. I'll try some things out tho. Thanks! I'll keep you updated
  • Thanks.  But most likely, it's simply Apple changed something that breaks old code.  They've done it at least 3 times since I started coding for it (one of them was REALLY devastating, broke every single Solomon's Keep savegame, replaced all saving/loading with "crash").
  • In the same vein I'm sure, but it also crashes out whenever I type a character past the @ symbol. In other words, if I were to type in the email address it will crash the second I type the first b. So.. poop@b... then crash. Every time, any email address
  • Hm, that would definitely not be anything specific about the code (@ is no different than anything else).  So I suspect that it has something to do with some attempted autocomplete or whatnot that didn't used to be in there. 

    Okay, when I do the 64-bit fix, I will see what's causing it!
  • Yes! Yes! i turned off all keyboard features like autocorrect, autocapitalization, spell check etc etc and i can sign in, post levels, rate levels etc It worked! Thanks a bunch! Now i can start work on PB5!
  • edited April 2017
    Okay, I just want to toot my own horn here... I am a True Master Diagnostician!

    I'm glad there's a workaround.  I'll see what I can do to fix it when I update.

    Doubtless Apple adjusted things so certain features default to on, instead of off, and never mind backward compatibility.
Sign In or Register to comment.