Bribe Destiny and other Boneyard bugs

#1: I see that just as with Keep, Bribe Destiny has to first be enabled in the options menu. However, it still shows up in the list of perks even when disabled. Can't test if it actually works, though. Gonna take a long time until I can afford it. (Though I approve of making it ridiculously expensive, given that it arguably breaks the game.)

#2: The game froze on me the first time I got an interstitial ad.

#3: There have been two occasions where I got a game over, yet instead of Solomon taunting me, all I heard was a brief sound glitch.

#4: The stats screen has some leftovers from Keep that should be irrelevant here. Namely, the current difficulty and the number of deaths.

#5: After selecting a skill, the game sometimes accepts no input for maybe a second or so. This occasionally causes me to take unavoidable damage.

#6: When spoken to, the Witch who sells you perks uses a male voice clip.

#7: For several runs, I went with the perks that grant you Rush 1 and three extra potions of each type. However, during one of these runs I wasn't offered a discount for going with the same combination as last time. Think it was the fourth run. Don't think I forgot to get the perks in my previous run, but I can't say for sure.
«1

Comments

  • Just remembered another bug. After one of my first runs, I got a popup telling me my highscore has been submitted to Gamecenter. It was briefly visible at the start or end of some subsequent runs as well.
  • #1: Oops, Boneyard should not have that in settings.  That's what I get for copying the settings right from Keep.

    #3: Do you have the volume adjusted?  Solomon is being a bastard about the sound volume in the first build.

    #6: That's actually YOU saying "ahem," but I think it's not adjusted for the female wizards either.

    In a couple days, I will give testers gold, because we want to check everything.
  • #3: Yeah, I lowered the sound effects' volume.

    #6: I see. The female protagonists in Keep also use the male "ahem" clip, so I always assumed it belonged to the NPCs.
  • #6 It's more an issue of a lazy programmer guy and his microphone that broke.
  • Okay, here the second batch of bugs:

    #1: I somehow ended up with a broken save file that always crashed the game after the initial loading screen. Unfortunately, I deleted it before realizing it would be helpful to upload it.

    #2: I don't think there's much of a point to the "Awesomeness" stat here either, is there? Another accidental leftover from Keep?

    #3: I once picked the archchancellor's "(Nobody volunteers)" dialogue option after letting Morth step forward. The archchancellor then selected him. However, this caused him to be deselected instead.

    #4: Just like Keep, this game also has a habit of resetting when suspended. I have switched phones after beta testing Keep, yet still have this issue even with my new phone in both games. It's pretty strange that I seem to be the only one affected by it. Or is this completely normal on Android?
  • edited October 12
    #1: Darn... yes, in the future please send me these suckers!

    #2: Just keeping it for consistency (remember, this is a PORT, not a revamp, except for the perks)

    #3: That's fine... it's an old "bug" from iOS days... my policy is I want to be working on KeepHD, not spending the next six months chasing non-critical bugs from iPhone 1 days. :)

    #4: When you say resetting, do you mean everything is wiped, all perk progress, etc?    Is there any information you can give me about this, like what you're doing at the time?  There's no code in the game to wipe everything, the only thing I can think of is that you start a fresh new game and it never saves, somehow.

    Or... is it possible it's NEVER saving for you?  That any time the game gets killed from the background for memory reasons, it's wiped?  To test that, try force quitting the game, see if your data persists.
  • #4: Sorry, I phrased that poorly. What I meant was that it simply restarts, meaning I end up back on the title screen. I don't lose any progress aside from what happened after the last time the game saved.
  • Oh... so is this correct:

    1. You play
    2. You hit home to go do something else for a bit
    3. Now you come back to the game, and it's at the title screen (and loading screen too?)


  • Okay... so the way these modern phones work is, they keep the game running in the background-- unless they need the memory.  Then they shut it down, which forces the re-load. 

    Let's test this... play Boneyard, hop out and do something you know is very low memory (maybe just go to your home screen, the pop back into Boneyard).  What does it do then?
  • edited October 13
    Well, would you look at that. My save is corrupted again. I assume you're a lot happier about this than I am, huh?

    I'll figure out how to upload it tomorrow.

    Edit: Just tested your instructions with Keep instead. It resumed correctly. So it would appear this behavior is normal.
  • My God, I am delighted if you have a corrupted save!  If you have dropbox, just drop it in there and send me a link.  If you don't have dropbox, it's free!  (Or find any other place where you can upload stuff and give me a link to download)
  • edited October 13
    I know how to upload files. I just haven't properly familiarized myself with Android's file manager yet. I'm simply too tired to do it right now.

    Don't worry, you'll get your delicious broken save file tomorrow.
  • I hunger.
  • edited October 14
    Turns out uploading files on Android is a LOT more annoying than with a PC. At least when using a site as mobile-unfriendly as Mediafire. But after much frustration, I finally did it. Is this what you need?
  • Yep, that's what I needed.  For future reference, I only need the "sandbox" folder.  Also, it's pretty easy on Android to plug it into a PC and browse it just like it was a USB stick.
  • Bad news though-- there's no savegame in here, the save folder is empty.  Did you play a new game?  Starting a new game wipes out everything.
  • edited October 14
    No, I just played the game normally for a day or two after the first save wipe. Then the game suddenly started crashing after the initial loading screen. Didn't do anything further with it.

    Just to make sure, I can delete my save data and start over now, right? Or is there anything else I should check for first?
  • You can wipe.

    But when you start, it asks you about continuing your last game?  Wait, double check one more thing for me... inside the sandbox folder, there's a folder called save64.  Is that folder empty? It wasn't included in your zip file.
  • I used an App called ZArchiver to pack the entire folder. I can't imagine anything in it having been skipped unless there is data in there that it somehow doesn't have read permission for. I'll compare the content of my archive with the original tomorrow.

    Also, I never reach the point where the game can ask me about anything while using a corrupted save file. I don't even make it to the title screen. Plus, I never actually left a run suspended so far. Only ever quit the game after dying.
  • edited October 14
    Hey, I'm confused now... tell me if this is correct, this is what I thought you mean when you say your save is corrupt:

    1. You play a bit
    2. You quit to do something else (but why, ever?)
    3. Now you come back into Keep-- it's got you at the title screen
    4. You hit play, and it says "continue last game?"
    5. You hit yes, and it crashes...

    That's what I thought previously, but your latest one makes me think this....?

    1. You play
    2. You quit
    3. You try to start the game and it stops on load
    4. To fix, you have to uninstall and reinstall


  • Yup, it's the second scenario. With a corrupted save file the game crashes immediately after the initial loading screen.
  • Okay... I will have to look into that.   Because I opened it here fine... hm.  Can you send me LOGCATS of this?
  • That requires USB debugging, right? Will have to look into that. Hope there's a way to do it without the USB cable (which my phone's previous owner didn't give me). Otherwise, I guess I'll have to buy one.
  • Here's the instructions, posted by a kindly soul from Reddit:

    * * *

    You send logcats to show a developer exactly what happened when an
    app does something that it isn't supposed to do. Developers depend
    heavily on this especially when the reason behind an error isn't clear.

    Instructions: (I recommend reading the whole thing through once before following along)

    1. Enable "USB debugging" on your android device under developer
      options. If you don't have developer options enabled, go to Settings
      > About > (Software Information) > press "Build number" 7
      times.

    2. Connect your Android device to your PC.

    3. Install Android Studio on your PC, there are instructions on how
      to install the drivers to your device based on Windows version. https://developer.android.com/studio/run/oem-usb.html (1.9 gbs)

    4. Download and Extract an Android Debug Bridge on your PC (adb executable)
      https://developer.android.com/studio/releases/platform-tools.html (7 mbs)

    5. Go to the folder where you previously extracted the adb
      executable, it should be called platform-tools. Shift+Right Click an
      empty space and click "Open command window here."

    6. In the command prompt, type "adb devices" to check if your device is properly attached.

    7. Type "adb logcat > logcat.txt". The command prompt might say
      "- waiting for device -" or it might not say anything, it doesn't matter
      as long as the device is attached.

    8. Now, you will try to replicate/recreate the error (or whatever)
      on your device. Remember to keep it connected to the PC at all times.

    9. When you finish, you can close the command prompt and there
      should be a text file called logcat. You can email the file or upload it
      to dropbox.

    Tip: When performing the error, try to complete it in as little time as possible to reduce the size of the .txt file.

  • edited October 15
    If you are an ace, you can try to follow Google's advice on how to get them:
    https://developer.android.com/studio/command-line/logcat.html

    But Google instructions are for autists.

    And here's a slightly less autistic version, that doesn't appear to require Android Studio:
    https://android.stackexchange.com/questions/33216/how-can-i-get-a-logcat

  • Okay, I didn't have the time to try to figure this stuff out the last days, but I'll give it a shot now.

    It's unfortunate that I had to suspend testing of the game for several days, but the opportunity to catch a major bug nobody else is having should be worth it.
  • Hey, wait until the next beta rolls out.  I gave a shot at fixing it blindly, it might have worked.
  • Okay, I'll wait until tomorrow then to make sure I have it installed.
  • Still downloading Android Studio. In the meantime, I tried running the game one more time. Still didn't work. So unless my phone somehow neglected to update it, this issue still isn't fixed. Hope I can shed some more light on this later.
Sign In or Register to comment.