Solomon's Boneyard Beta 5

edited October 2017 in Beta Testing
Beta five is currently being rolled out.  Remember that it can take anywhere from 5 minutes to like six hours to reach your part of the world.

Your menu screen should say "Beta 5" otherwise it hasn't reached you yet.

New testers, you will need to follow this link in order to opt in:

So I took down a few of the android bugs... Google has still not gotten back to me about the app store crashing, and I will remind them that I am still having problems tomorrow. 

Note that purchases are live.  They're not supposed to be, but somehow they are-- this too, is some kind of Google Play Store Mystery.  You can still use "watch ads" to get more gold than you normally would, though.  That will probably change in the next update, so stock up.


o Fixed a couple googly-androidy things.
o A checkbox to enable/disable bosses is now in settings
o There's a newsbone now, like in the recent Keep update.
o Perk tonic buying + bargain bags now work properly
o Everweld will no longer allow you to get skills beyond the skill cap.
o Item descriptions no longer spill off the square.
o Damage resistance now properly can't exceed 95%
o Limited the number of imps that can spawn from the boss (let me know if this number does not lag)
o Fixed a glitch with retaining "no ads"
o There are new fates


  • Fancy news skull! 'Kill the ads' looks good now too! :D
  • Yay! "Kill the Ads" option is now works nomally.

    And oh, New FATES! "Magic Trap" & "Explosive Shield".
    is it works same as Solomon Dark?

  • Yep, I moved them right over.  I might add some Dark bosses too, but not until after launch-- the clock is ticking here.
  • Waiting for a 3rd 35% Damage Resist Ring to drop, in order to try the 95% Damage Resist cap. Lost all my rings on crash after I did the update and tried to coninue my in-progress game.
  • Lost rings on crash-- wait a minute.  What kind of crash, what happened?  Report crashes!  Include logcats if you can.
  • edited October 2017
    I was mid a game on Beta 4. Updated to Beta 5. Pressed Play on Main Screen. It asked if I wanted to resume and I chose "Ye"s. The game loaded with me mid being swarmed by 5 million imps with God Mode - 3x 35% Damage Resist rings equipped. The game was stuck with no movement and partial black on side of screen. Closed app down. Reopened an pressed Play on Main Screen. It did not Resume saved game & all rings were lost. Unfortunately, I was at the airport waiting to board my flight, so no logcats.
  • Chalked the crash up to factors in saved game that shouldn't have existed with new Beta Build. I can try to regress when I get my 3rd ring again.
  • Okay, yes, sounds like essentially memory overload from imps, which yes, could blow up the savegame.  I will wait for an update.
Sign In or Register to comment.