Can't view Ads for gold.

On iOS iPhone 6S+ in both solomon's keep and Solomon's Boneyard when I click the "Get Gold" button and select "View Ad For Gold" it loads up an ad showing a black screen and a play button.  If I click the play button it shows me an ad with a scrollable image.  The X button is there and if I click it the ad closes however I am not rewarded any gold. I have tried waiting for over 2 minutes as most of the ads have a timer even though there is no timer showing in the ad.  Been like this for a couple days now.


  • I have the same problem on my iPad and an my iPhone 5s. Both are on iOS 11.1.1.
    On some adds the video window shows up empty and closes after a few seconds to show a static add with the link to the app store.
  • Update:
    Apparently my problem was due to a slow internet connection, I’ve now moved to the next location on my trip and here the ad videos are working. The network here seems to be faster than at the previous place, for example YouTube videos play without buffering breaks as well.
  • Okay, good to know.  It's too bad admob doesn't pop up a little "Your internet is too slow" type notification.  I've got similar problems with the google play store, which checking if purchases are bought.
  • Slow wifi is not the issue.  The ad being loaded is the issue.  It loads the same thing I said in my original comment every single time in both apps.  Doesn't matter if i'm on my work's wifi, home wifi, or verizon.  This should be fixed as Raptisoft is losing money at this point.  I was viewing about 20 ads per day.  Now i'm viewing 0.
  • Just tried to view an ad again and on the 3rd attempts, I was clicking the play icon as fast as I could I got a pop up I have never seen before saying, "The ad failed to load! To view ads to earn gold, please disable Limit Ad Tracking in your Privacy -> Advertising Settings!" I thought this might be the issue, however once I went to my settings to disable it, it was already disabled.
  • And another update... In my iOS Privacy -> Advertising Settings I clicked on "Reset Advertising Identifier" and reset that.  Went back into the app and the first time trying to view an ad it failed, but on the second time it worked.  It is now working every time for me.
  • Thanks for the info... I'll add it to my list of "OS solutions" for problems that look like they're my fault, but actually aren't! :)
  • No problem, I am an app dev as well so I get the frustration of how hard it is to troubleshoot issues like this when it is completely unrelated to your app.  I don't understand how both Android and iOS make things like this so complicated.  Adding push notifications to an app last year and iOS docs said, "There is no gaurentee all devices will receive the notification"  Like WTF Apple.   
  • Yeah, the systems are crazy... especially the in-app purchasing is difficult to test, across the board, on all systems.  You'd think they'd just put a little checkbox that says "TEST MODE" that you can turn on or off as a developer.  But no-- until you publish, on ALL systems, you really don't know for sure that it's working!

    But I bet the notifications just says that because at some point, a developer sent a notification, and it didn't get to a device that was turned off or something, and that developer grabbed a lawyer and sued Apple.  So many of the wonky disclaimers everywhere come from that.
Sign In or Register to comment.