RwK Beta 2

RwK Beta 2 is submitted and should be populating.  I have added a few more tiles here (to make up for the bug fixes).  I also plan to add some more in an update after release.

On the bug fixes: The nature of most of these bugs are such that it makes the game unplayable for new players.  While it's fun for hardcore people, it essentially chases new people out of the game because they perceive that levels have been uploaded that cannot be solved.  I've now added conveyor belts and bouncers, which should give a lot of new configurations for challenges (you can even put the Kitty on a conveyor belt if you want to make a level like "get to Kitty before he gets dumped in the lava).

So anyway... yeah, I have to fix the bugs.  I would never have allowed them to go so long if Apple hadn't changed their compiler so much that I could no longer compile.

But anyway, update is out and should be populating... give it a try!

Comments

  • edited January 15
    #2 seems to be fixed.

    #12: When opening the pause menu while teleporting, the background continues to shake as long as the pause menu remains open.

    #13: Gold key cards don't show up in the inventory.

    #14: The game just froze when I was about to start the level "Short and bossy". I have successfully played this level before.

    Here's a photo: http://www.mediafire.com/view/4z0mttmawk2n8js/HNI_0096.JPG

    I also created a logcat of the game in this frozen state. I didn't capture the moment this began, but perhaps it's still useful. Will send you a PM.

    Edit: Well, wouldn't you know? It happened again the next time I tried to load this level. In fact, it now always happens in this level, but none of the others. So I was able to capture all of it. Another logcat coming right up.

    #15: Don't know if this is actually a bug, but you can select the two blank tiles in the editor. Placing them just erases stuff.
  • Hi, thanks for the detailed report...

    #12: I probably won't fix this because it's just visual crappines... I can't make RwK too nice because of all the legacy code, when I do the sequel I'll try to get closer to dat nintendo quality.

    #13: Well crap... okay, gonna look into that!

    #14: If you try to play it again, do you have the same problem?  If it freezes again, I would like to give you a code that will send me your machine's state so I can try to duplicate it here.

    #15: Yeah, those will be taken up when I update... so in the meantime, I don't mind this.
  • #14: Guess you overlooked my edit. Yeah, it always happens in this version.
  • I'm going to PM you with a code.
  • It seems like it would be a much easier fix to just add an "expert only" tag to levels, then we'd all clearly mark our levels that use glitches.
    You've already added tags to levels it seems, so it seems unlikely that someone new to the game would attempt a hard, or tricky level and somehow assume that it couldn't be beaten with their totally novice skills.
    Seems like, especially with tags, it wouldn't be an issue.
    And again, my only concern is the removing of functionality especially when it seems unnecessary. 
  • The conveyor belts are really cool. Very nice addition!

    I hesitate to even mention it, but there's a really cool effect when using the conveyor belts and the bump pad (also cool). It creates a sort of ice-block effect. Please don't remove it, it's cool.

    Things that might be addressed: if there is a block hovering above the conveyor belt, a monster (the red one anyway) will act as if there is no conveyor belt until past the overhanging block. (I know it's vague and wordy, but I put examples of it in the level Fomb test 9)

    Also, I couldn't reproduce it but there was some conveyor belt switch glitch that made the conveyor belt very slow. Easily walkable by both the robot and the monster. It seemed I hit the switch again before it had completely changed? Maybe? I only played through my level a couple of times and couldn't get it to happen again, so I don't know exactly what caused it. 

    Anyway, conveyor belts and bump pads, ...very cool.
  • #16: When entering a code in the "Haxxor Stuff" menu, the camera moves a bit too far down on my phone: http://www.mediafire.com/view/zq613g0o47te9gi/HNI_0098.JPG
  • I know.  This is an android problem that seems to be random by device.  All my other games have the same problem.  It seems like some android devices, at SOME TIMES (but not all) report the keyboard height oddly, so I think the textbox is behind the keyboard and I move it upward so you can see it... except the keyboard isn't actually that height.

    I don't know the solution for this.  It happens on my device too, and the device simply reports my on-screen keyboard too big-- and then sometimes it reports it correctly.  I haven't found anything that makes this consistent.
  • edited January 16
    Funky it almost looks like the keyboard is pushing the game up instead of overlaying on it.

    I dunno coding but just out of curiosity does this help out any?
    https://stackoverflow.com/questions/5516216/how-to-avoid-soft-keyboard-pushing-up-my-layout
    Edit:
    Or maybe sometimes looking at it from the other end helps some?
    https://stackoverflow.com/questions/34197400/keyboard-covers-screen-instead-of-pushing-up-layout
  • edited January 16
    Hm... hey War2K that might be something... it might be that it's Android auto-moving the layout.  I will look into that.  But then I'd expect it to do it all the time reliably, and what I'm getting is sometimes it happens, sometimes it doesn't.

    But I have put that into the next beta, so let's see what happens there.  If it fixes it, I'll give you something, because I have been bedevilled by this for a while.

    BTW, Kitty Content creators... let the record show that if you stack up those Robot-bouncers, they bounce him higher.  I.E. if you put several on top of eachother.
Sign In or Register to comment.