Too easy to lose rings

In the current scavenging system it is too easy to accidentally delete all of your rings. It’s just plain silly to include a button which will delete all of your best equipment all at once. Furthermore it can be triggered if your save game is lost before a death sends your inventory back to the scavenger. I know that it is meant to be a joke and it does warn you beforehand but it’s completely unnecessary and more importantly unfun and frustrating. AND to top it off it makes a genuinely useful feature, the ability to start over without having to kill yourself which is annoying, and makes it completely useless because it also deletes all your gear. Seriously who actually WANTS this?

I just lost all of my rings. I don’t remember wether it was because I was in autopilot and hit new game instead of going back in and dying, which is again annoying, or if my game was lost but I’m really upset that all the rings I accumulated are now gone.

Please change it back to how it was before (Whatever system you had with the magic bag that always saved what you had) when I didn’t have to worry about losing my rings. I know it’s supposed to be the wizards running off but don’t let a joke ruin the game.


  • > It’s just plain silly to include a button which will delete all of your best equipment all at once.

    What button is this?  Do you mean if you reset the game so that your wizard runs away?

  • Yes that one. There is really no good reason for this to be there
  • edited November 2017
    If you leave the game and goto the main menu it will ask you if you want to continue your game (yes/no option) selecting yes bring you back where you left off, and selecting no means you forfeit what you were carrying while in the graveyard (and only what you had in the graveyard, but you keep everything you left in the scavenger. Unless your taking everything in with you to the graveyard when you really shouldn't be doing that.). When pressing no the game warns you that this cowardly act will make the wizard take everything he was carrying with him. But other than that there's no real hard reset button that makes you lose anything you aren't willing to lose (other than going into the apps manager and reseting your games data).

    I think you may have glitched and lost your save. I believe the scavenger is a separate file so whatever he has holding for you will still be there.
  • The scavenger is empty I checked. I probably just hit restart and confirm on without paying attention since I was tired.

    I know that it does warn you that you will lose your rings if you quit but my complaint is that this is completely unnecessary and prevents you from using the actually useful feature of being able to restart right away
  • It happened to me that same. I started a game, as always i took my perks and all the usefull rings, then i closed it because i had something to do. When i came back to play, my last game wasnt there, it was the main title screen and all my rings were gone:/
  • edited November 2017
    I wouldn't care about my rings disappearing if I simply quit the game instead of dying IF I hadn't already lost a multitude of rings by my game accidentally not saving. I leave the game to answer a text message or check an email and I come back and either the game is frozen, crashes, and sometimes gives me the option to continue, or it just restarted the game the second I left it, put me back at the main menu, and deleted my save. I suppose the obvious answer to this is to not leave the game while playing a match and just play it through till you die, but it still sucks that it's so easy to lose rings because of bugs.

    I'd still pay gold (a lot more gold than I have to pay now, honestly, since the perks are back to the way they were) to access my rings every round, but I also don't really like the idea of being able to lose them so easily. I know the system, and I know that if I leave a game my rings will go away, but I don't know when the game is going to decide to let me continue my save or not, which bothers me. I guess we have to deal with it for now, since RWK seems to be priority now that most of the big bugs and whatnot are gotten rid of in Boneyard, but I would like to see the scavenger system touched up on a bit. At least making it more stable, I guess? If that means we can't lose rings by quitting the game and the only way we can get rid of rings is unforging them, I'm totally fine with paying more gold.
  • I lost all my rings two times. I posted about the first loss in another post shortly after the game was released so I won’t repeat it here. The loss yesterday happened like this:

    Was in the middle of a game

    Got a text

    Answered text

    Hit home button on my iPhone to come back to game

    Saw resume or quit game prompt

    I am certain that I hit resume (button on left) and then got another message which was the one about the cowardly wizard and I accidentally hit ‘yes I was sure’ because I wasn’t expecting another prompt

    Started a new game and scavenger said it had nothing for me

    Super frustrating. Don’t want to have to farm all those rings again that took me hours and hours to get =[

  • Okay so.... was feeling like I could do the grind again after venting in last post so I started just started a new game with the 2 ring and 1 ring perk and was lucky enough to get a +2 damage and a +25 xp ring. I was playing the game and had just leveled when someone started talking to me and my screen timed out while I was talking to them. When I unlocked my phone a minute later the game was still there with my skill up options but when I tried to select one I wasn’t able to. The game then crashed. I went back into the game and what do you think happened? Game had restarted and scavenger had nothing. Very irritating.
  • Rani, the game should be saving all data at the moment of level up (prior to displaying the level up screen) on the most recent version.  Is it not doing so?
  • I’ve since lost everything 2x. I originally lost 3 100% experience rings and 500% gold due to crashing, then I decided to play again and have since lost another 500% gold ring, +5 damage and +1 battle mage, +2 to all skills and +2 frost jet +1 cone of ice.

    Mother game saves my gold, but not my rings upon crash. Most recent glitch is where I leave game and come back, it crashes and says worked 4x, but the very last time it crashed completely and is when I lost my rings for the second time.

    I hope you are able to implement a type of code for rings to give us some of what we’ve lost...would give me the desire to play again. I’ve spent probably 50+ hours playing since the new port to iOS 11 and I love the game, just can’t find it in me to play hours upon hours again only to lose everything I’ve gained a 3rd time.

    Also a suggestion for game play would be to put shield and other attacks on bottom left above thumb nail rather than the right. That way we can continue to attack while using attack or shield.
  • You guys can save the game when you want to pause it by tapping the ? sign and manually hitting leave game, then exiting. Not super convenient, but it'll save your rings until there is a hotfix.
  • Thanks for the tip, Jarhead. That’s good to know. I also just lost my rings (battlemage +2 and battlemage +2 + 20% mana recovery) simply because I left my screen to black out as I was getting something from the kitchen. Although my rings are easy enough to find again, it's frustrating and I can't imagine what it would be like to lose epic rings this way.
  • I abandoned SB because I got tired of losing my rings. :/

    It's making playing unnecessarily stressful, always having to make sure you save and exit properly, and that you don't missclick at the start screen and let the wizard 'run away' with all your good rings.

    My suggestion: if the game doesn't save properly from a crash/app switch, etc. or you choose to reset the current game, make it so you lose only the progress you made since you started that run. So just the gold and rings you gained during that run will be lost. This seems to be what most other games would do anyway.
  • I won a ring of plus 1000 percent gold. Then lost all my rings. VERY frustrating.
  • Thats rough Roger, been trying to get a 1000% gold ring.
  • I got one, then immediately destroyed it with the Unforge ... darn. :-( Raptisoft needs to put an “Are you sure?” option for any time a player opts to unforge an epic ring.
  • edited December 2017
    If you're on Android or jailbroken iOS, you could make a backup of your save data. It'd be a bit tedious to keep it up to date, but that way, you could restore any accidentally deleted rings without losing too much progress.
  • Yes, Jarhead, it’s tough...especially considering that gold is very important in this game. That ring was a path to self improvement. Ha! So....I’m gonna wait for a patch before attempting to play again. Love the game, but the possibility of losing everything is too much.
  • Hey, I have a quick question, because I am getting mixed reports:

    Is everyone losing rings by accidentally restarting the game (i.e. the cowardly wizard runs away) or are people still losing rings via game crashing glitches (I am aware of the iOS problem when you get a message and you switch apps, so I'm mainly asking about other methods).
  • edited December 2017
    If I turn off the Ipad, or minimize the app it doesn't save the game the way it should. When I reopen, usually i'm back in the game where I was previously, but all rings are gone. It's not because the cowardly wizard ran away. Game isn't auto-saving like it should be. The only way to pause the game without losing everything is to hit the ? and leave game manually, then exit.
  • I’ve lost them from a bug while upgrading to hurricane I believe. The game froze, then cleared itself, when I reopened, it was a totally new game with no rings. The other crashes have come from exiting the game, come back and it’s frozen. It then exits itself and when I reopened I had to start over. The second portion happened 2x before I stopped playing.
  • edited December 2017
    Sometimes I'll've killed a boss, gotten, say, 2,500 gold, pause the game, turn off my phone to go do something, come back, have the game frozen (aka, crash), resume my last save because I thankfully used the leave game button, but then the 2,500 gold I got from that boss was gone, and I was set back a couple minutes of gameplay. If I hadn't used the leave game button, I'm certain that all of my rings from that game would have been gone, and all of the gold I had earned wouldn't have registered. So if I leave the app at all, whether it be by switching apps or just turning off the phone, the game usually freezes.

    Also interesting to note, I was finding a bazillion names of gravestones, and after the game froze and crashed and I resumed the game, all of the flowers on the gravestones were gone, which I assume also means the game didn't count those towards the achievement.
  • @JarHead, can you provide any more details into this?  I don't know of a way the game could save your location without also saving your inventory-- because they're all in the same file/same place. 

    @MrStrouse, okay, that's the behavior I'd expect from a crash, except that it should have recovered you at your last levelup.  There's something funky about iOS and switching from the app, and I'm trying to figure out exactly what it is (when I use my own, it operates fine, so it must be some specific thing I'm not doing).

    @MoroVere, that's something to do with the way I tried to "force" iOS to save the game, I think.  It's frozen because the app has not yet reported "I saved!  I can go idle now!"  I am working on that for the next update.
  • @Raptisoft, When I first started playing after the update, I would be going through the game as normal, had maybe 4 rings, then paused the game and turned off the Ipad. Had to eat some turkey. When I hit the on button later, the Ipad was sluggish and took several moments to log in. The game had crashed and I had to reopen it. It didn't remember anything, my rings were gone, and I had to start over. After messing around with it a bit I figured out the temporary work around. 

    A bit later I was helping cook some food, paused the game and turned it off, then immediately panicked and turned it back on, cursing my old habits. It took a second or two, but I did it fast enough I was still in the game, but my rings had disappeared. I could have been a few levels behind where I was like @Morovere, and maybe I had just lost the recent data, and recent rings. I just remember tapping the spot where my xp ring used to be, wondering if there was a god :(

    Since then I've been using the manual leave game button. Thanks for the quick reply, look forward to the last update.
  • dmd
    edited December 2017
    I had this (iOS):
    Left the game
    Resumed the game
    App crashed
    Restarted app, could resume at an earlier savepoint
    App crashed
    Restarted app, can't resume, rings gone
  • edited December 2017
    i suggest you this video of my channel for the bug/crash problems. Maybe it can help you! 

  • DMD, please make sure you are on the latest version.  I just fixed/updated that problem late last week.
Sign In or Register to comment.